using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\*{1,6}( \[[ xX]\])? {1}";
string input = @"
* dfdsfdsf
** fdsfdsfsd
*** [ ] ffsdfdsf
** [x] dffdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}