import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\*{1,6}( \\[[ xX]\\])? {1}";
final String string = "\n"
+ "* dfdsfdsf\n"
+ "** fdsfdsfsd\n"
+ "*** [ ] ffsdfdsf\n"
+ "** [x] dffdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}