package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-Z0-9]{2,4}-[a-zA-Z0-9]{2}-[a-zA-Z0-9]\b`)
var str = `aaa-b3-c
a3-b6-c
aaaa-bb-c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}