re = /\b[a-zA-Z0-9]{2,4}-[a-zA-Z0-9]{2}-[a-zA-Z0-9]\b/m
str = 'aaa-b3-c
a3-b6-c
aaaa-bb-c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end