package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ ]*\n)+`)
var str = `abc
d
s
s`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}