use strict;
my $str = 'abc
d
s
s';
my $regex = qr/([ ]*\n)+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";