using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".(?=.$)";
string substitution = @"$0-";
string input = @"Jan104aca";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}