use strict;
my $str = 'Jan104aca';
my $regex = qr/.(?=.$)/mp;
my $subst = '$0-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";