#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:[1-9]\d\d?,\d{3}|(?:[1-9]\d?|1[0-4]\d),\d{3},\d{3}|150,000,000)(?!\S)"
Local $sString = "10,000" & @CRLF & _
"10,001" & @CRLF & _
"10,100" & @CRLF & _
"100,000" & @CRLF & _
"999,999" & @CRLF & _
"149,999,999" & @CRLF & _
"150,000,000" & @CRLF & _
"55,555" & @CRLF & _
"99,999" & @CRLF & _
"73,129" & @CRLF & _
"834,101" & @CRLF & _
"1,333,333" & @CRLF & _
"149,000,000" & @CRLF & _
"20,111,000" & @CRLF & _
"99,001,000" & @CRLF & _
"10,001,000" & @CRLF & _
"10,999,999" & @CRLF & _
"2,999,999" & @CRLF & _
"950,000" & @CRLF & _
"999,999" & @CRLF & _
"910,000" & @CRLF & _
"949,999" & @CRLF & _
"950,000" & @CRLF & _
"" & @CRLF & _
"949,999,999" & @CRLF & _
"1,999,999,999" & @CRLF & _
"100,949,999,999" & @CRLF & _
"1" & @CRLF & _
"1,0" & @CRLF & _
"9,000" & @CRLF & _
"9,999" & @CRLF & _
"5,555" & @CRLF & _
"250,000,000" & @CRLF & _
"9,999" & @CRLF & _
"100000" & @CRLF & _
"150,000,001" & @CRLF & _
"150,000,100" & @CRLF & _
"150,001,000" & @CRLF & _
"150,100,000" & @CRLF & _
"151,000,000" & @CRLF & _
"9,150,000,000" & @CRLF & _
"160,000,000" & @CRLF & _
"000,000,000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")