# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?:[1-9]\d\d?,\d{3}|(?:[1-9]\d?|1[0-4]\d),\d{3},\d{3}|150,000,000)(?!\S)"
test_str = ("10,000\n"
"10,001\n"
"10,100\n"
"100,000\n"
"999,999\n"
"149,999,999\n"
"150,000,000\n"
"55,555\n"
"99,999\n"
"73,129\n"
"834,101\n"
"1,333,333\n"
"149,000,000\n"
"20,111,000\n"
"99,001,000\n"
"10,001,000\n"
"10,999,999\n"
"2,999,999\n"
"950,000\n"
"999,999\n"
"910,000\n"
"949,999\n"
"950,000\n\n"
"949,999,999\n"
"1,999,999,999\n"
"100,949,999,999\n"
"1\n"
"1,0\n"
"9,000\n"
"9,999\n"
"5,555\n"
"250,000,000\n"
"9,999\n"
"100000\n"
"150,000,001\n"
"150,000,100\n"
"150,001,000\n"
"150,100,000\n"
"151,000,000\n"
"9,150,000,000\n"
"160,000,000\n"
"000,000,000\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.