import re
regex = re.compile(r"\(*(\(\d{4}_-_\d{2}_-_\d{2} \d{2}:\d{2}[\s|]*[ap]m\))\)*", flags=re.MULTILINE)
test_str = "hhhh ((44_-_44)) ggj ((2022_-_02_-_18 20:00 pm)) ((((2022_-_02_-_18 20:00 pm))) (2022_-_02_-_18 00:00 am)"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)