package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-ZÇ]{4,9}`)
var str = `ABCDEF
ÇÇÇÇÇ
JANEIRO
FEVEREIRO
MARÇO
ABRIL
MAIO
JUNHO
JULHO
AGOSTO
SETEMBRO
OUTUBRO
NOVEMBRO
DEZEMBRO
janeiro
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}