re = /[A-ZÇ]{4,9}/m
str = 'ABCDEF
ÇÇÇÇÇ
JANEIRO
FEVEREIRO
MARÇO
ABRIL
MAIO
JUNHO
JULHO
AGOSTO
SETEMBRO
OUTUBRO
NOVEMBRO
DEZEMBRO
janeiro
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end