#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(.*embed\.vevo\.com)\/?(\?)?(.*video=([^&]+))?(&)?(.*partnerId=([^&]+))?"
Local $sString = "https://embed.vevo.com/?video=USSM21700367&partnerId=346c2586-d3f8-4b75-ba0d-398fdb6e4c08"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")