$re = '%(.*embed\.vevo\.com)\/?(\?)?(.*video=([^&]+))?(&)?(.*partnerId=([^&]+))?%i';
$str = 'https://embed.vevo.com/?video=USSM21700367&partnerId=346c2586-d3f8-4b75-ba0d-398fdb6e4c08';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);