$re = '/^(?!.*\*[*#]|\d*#$)[*\d]*#?$/m';
$str = '123
*123
*123*
*123#
*123*4
*123*4#
1
*1
*1*
*1#
*1*1
*1*1#
*1
1**
*1*#
1#
**
**3
#
*#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);