re = /^(?!.*\*[*#]|\d*#$)[*\d]*#?$/m
str = '123
*123
*123*
*123#
*123*4
*123*4#
1
*1
*1*
*1#
*1*1
*1*1#
*1
1**
*1*#
1#
**
**3
#
*#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end