import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<content>(?<type>.+?)\\/(?<sub>.+?)(?:\\+(?<suffix>.+?))?)(?:;.*?(?:q=(?<weight>[.\\d]+))?.*?)?(?:,|$)";
final String string = "*/*\n"
+ "text/html,application/json;q=0.9\n"
+ "application/json; charset=utf-8\n"
+ "application/json; xx=utf-8\n"
+ "text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8\n"
+ "application/javascript\n"
+ "application/x-www-form-urlencoded\n"
+ "application/ld+json\n"
+ "application/vnd.ms-excel\n"
+ "application/vnd.openxmlformats-officedocument.wordprocessingml.document\n"
+ "multipart/form-data\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}