import re
regex = re.compile(r"(?<content>(?<type>.+?)\/(?<sub>.+?)(?:\+(?<suffix>.+?))?)(?:;.*?(?:q=(?<weight>[.\d]+))?.*?)?(?:,|$)", flags=re.MULTILINE)
test_str = ("*/*\n"
"text/html,application/json;q=0.9\n"
"application/json; charset=utf-8\n"
"application/json; xx=utf-8\n"
"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8\n"
"application/javascript\n"
"application/x-www-form-urlencoded\n"
"application/ld+json\n"
"application/vnd.ms-excel\n"
"application/vnd.openxmlformats-officedocument.wordprocessingml.document\n"
"multipart/form-data\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")