re = /[A-Z]+(?![a-z])|[A-Z][a-z]*|\d+[a-z]+/m
str = 'ERISACheckL
ERISA404cCheckL
F401kC
DisclosureG
SafeHarborE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end