package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<multi>mul\((?P<num1>\d*),(?P<num2>\d*)\))+|(?P<do>do\(\))+|(?P<dont>don't\(\))+`)
var str = `xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
mul(6,9!
mul ( 2 , 4 )
mul(4*
?(12,34)
mul(123,4)
mul(44,46)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}