const regex = new RegExp('(?P<multi>mul\\((?P<num1>\\d*),(?P<num2>\\d*)\\))+|(?P<do>do\\(\\))+|(?P<dont>don\\'t\\(\\))+', 'gm')
const str = `xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
mul(6,9!
mul ( 2 , 4 )
mul(4*
?(12,34)
mul(123,4)
mul(44,46)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}