const regex = /^.*<email.*>(.*)<\/email>\n.*<sureName>(.*)<\/sureName>\n.*<geschlecht.*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*<email.*>(.*)<\\\/email>\\n.*<sureName>(.*)<\\\/sureName>\\n.*<geschlecht.*>', 'g')
const str = ` <email xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="xs:string">tarek68@gmx.at</email>
<sureName>IRADA Mohamed Tlig</sureName>
<geschlecht xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="xs:int">-1</geschlecht>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}