package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z\s]+)\s+([a-zA-Z0-9]+)\s+(.*?)\s*$`)
var str = `abcd efgh x23y mnop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}