$re = '/^([a-zA-Z\s]+)\s+([a-zA-Z0-9]+)\s+(.*?)\s*$/m';
$str = 'abcd efgh x23y mnop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);