package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]+)"`)
var str = `"DOE, JOHN W","35", "$12,945", "M"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}