import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<oldDomain>https?:\\/\\/(?:registry.yarnpkg.com|registry.npmjs.org|[^\\/]+))\\/(?<pkgFullName>(?:(?<scopeName>@[\\w-]+)(?:\\/|%2f))?(?<pkgName>[\\w-]+))\\/(?:-|download)\\/[^#]+-(?<version>[\\w\\.]+?)\\.(?<fileExt>\\w+)#(?<hash>\\w*)";
final String string = "\"@22g/utility-types@^8.10.0\":\n"
+ " version \"8.10.0\"\n"
+ " resolved \"https://local.duizhuang.com:4873/@22g%2futility-types/-/utility-types-8.10.0.tgz#b35831f1be7a13359946efa29783541aea63e1a9\"\n"
+ " integrity sha1-s1gx8b56EzWZRu+il4NUGupj4ak=\n"
+ " dependencies:\n"
+ " \"@types/react\" \"*\"\n\n"
+ "\"@babel/helper-annotate-as-pure@^7.0.0\":\n"
+ " version \"7.0.0\"\n"
+ " resolved \"https://registry.npm.taobao.org/@babel/helper-annotate-as-pure/-/@babel/helper-annotate-as-pure-7.0.0.tgz#323d39dd0b50e10c7c06ca7d7638e6864d8c5c32\"\n"
+ " integrity sha512-3UYcJUj9kvSLbLbUIfQTqzcy5VX7GRZ/CCDrnOaZorFFM01aXp1+GJwuFGV4NDDoAS+mOUyHcO6UD/RfqOks3Q==\n"
+ " dependencies:\n"
+ " \"@babel/types\" \"^7.0.0\"\n\n"
+ "\"@babel/helper-builder-binary-assignment-operator-visitor@^7.1.0\":\n"
+ " version \"7.1.0\"\n"
+ " resolved \"https://registry.npm.taobao.org/@babel/helper-builder-binary-assignment-operator-visitor/-/@babel/helper-builder-binary-assignment-operator-visitor-7.1.0.tgz#6b69628dfe4087798e0c4ed98e3d4a6b2fbd2f5f\"\n"
+ " integrity sha512-qNSR4jrmJ8M1VMM9tibvyRAHXQs2PmaksQF7c1CGJNipfe3D8p+wgNwgso/P2A2r2mdgBWAXljNWR0QRZAMW8w==\n"
+ " dependencies:\n"
+ " \"@babel/helper-explode-assignable-expression\" \"^7.1.0\"\n"
+ " \"@babel/types\" \"^7.0.0\"\n\n"
+ "\"@babel/helper-builder-react-jsx@^7.7.0\":\n"
+ " version \"7.7.0\"\n"
+ " resolved \"https://registry.npm.yarnpkg.org/@babel/helper-builder-react-jsx/download/@babel/helper-builder-react-jsx-7.7.0.tgz#c6b8254d305bacd62beb648e4dea7d3ed79f352d\"\n"
+ " integrity sha1-xrglTTBbrNYr62SOTep9PtefNS0=\n"
+ " dependencies:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}