const regex = /(?<oldDomain>https?:\/\/(?:registry.yarnpkg.com|registry.npmjs.org|[^\/]+))\/(?<pkgFullName>(?:(?<scopeName>@[\w-]+)(?:\/|%2f))?(?<pkgName>[\w-]+))\/(?:-|download)\/[^#]+-(?<version>[\w\.]+?)\.(?<fileExt>\w+)#(?<hash>\w*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<oldDomain>https?:\\\/\\\/(?:registry.yarnpkg.com|registry.npmjs.org|[^\\\/]+))\\\/(?<pkgFullName>(?:(?<scopeName>@[\\w-]+)(?:\\\/|%2f))?(?<pkgName>[\\w-]+))\\\/(?:-|download)\\\/[^#]+-(?<version>[\\w\\.]+?)\\.(?<fileExt>\\w+)#(?<hash>\\w*)', 'g')
const str = `"@22g/utility-types@^8.10.0":
version "8.10.0"
resolved "https://local.duizhuang.com:4873/@22g%2futility-types/-/utility-types-8.10.0.tgz#b35831f1be7a13359946efa29783541aea63e1a9"
integrity sha1-s1gx8b56EzWZRu+il4NUGupj4ak=
dependencies:
"@types/react" "*"
"@babel/helper-annotate-as-pure@^7.0.0":
version "7.0.0"
resolved "https://registry.npm.taobao.org/@babel/helper-annotate-as-pure/-/@babel/helper-annotate-as-pure-7.0.0.tgz#323d39dd0b50e10c7c06ca7d7638e6864d8c5c32"
integrity sha512-3UYcJUj9kvSLbLbUIfQTqzcy5VX7GRZ/CCDrnOaZorFFM01aXp1+GJwuFGV4NDDoAS+mOUyHcO6UD/RfqOks3Q==
dependencies:
"@babel/types" "^7.0.0"
"@babel/helper-builder-binary-assignment-operator-visitor@^7.1.0":
version "7.1.0"
resolved "https://registry.npm.taobao.org/@babel/helper-builder-binary-assignment-operator-visitor/-/@babel/helper-builder-binary-assignment-operator-visitor-7.1.0.tgz#6b69628dfe4087798e0c4ed98e3d4a6b2fbd2f5f"
integrity sha512-qNSR4jrmJ8M1VMM9tibvyRAHXQs2PmaksQF7c1CGJNipfe3D8p+wgNwgso/P2A2r2mdgBWAXljNWR0QRZAMW8w==
dependencies:
"@babel/helper-explode-assignable-expression" "^7.1.0"
"@babel/types" "^7.0.0"
"@babel/helper-builder-react-jsx@^7.7.0":
version "7.7.0"
resolved "https://registry.npm.yarnpkg.org/@babel/helper-builder-react-jsx/download/@babel/helper-builder-react-jsx-7.7.0.tgz#c6b8254d305bacd62beb648e4dea7d3ed79f352d"
integrity sha1-xrglTTBbrNYr62SOTep9PtefNS0=
dependencies:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}