using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AD=\+[0-9]{6}";
string input = @"AD=+172345AD=+272345";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}