package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`AD=\+[0-9]{6}`)
var str = `AD=+172345AD=+272345`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}