using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-PR-UWYZ0-9][A-HK-Y0-9]?[AEHMNPRTVXY0-9]?[ABEHMNPRVWXY0-9]? {0,2}[0-9][A-HK-Y0-9]{1,2}|GIR 0AA)$"";";
string input = @"G 83";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}