#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?email)^([a-z0-9_\.-]+)@([\da-z\.-]+)\.([a-z\.]{2,6})$"
Local $sString = "cookie.monster@sesamstrasse.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")