re = /^([a-z0-9_\.-]+)@([\da-z\.-]+)\.([a-z\.]{2,6})$/mi
str = 'cookie.monster@sesamstrasse.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end