re = /(?:https?:)?\/\/.*?(?=$|(?:https?:)?\/\/)/
str = 'http://foo.com/barhttps://bar.com//foo.com/foo/bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end