import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(mobile\\.|www\\.)?(twitter|x)\\.com([\\w/-]+)";
final String string = "https://twitter.com/lorem\n"
+ "https://www.twitter.com/ipsum\n"
+ "https://x.com/dolor\n"
+ "https://mobile.x.com/sit\n"
+ "https://fedex.com/amet\n"
+ "https://www.fedex.com/consectetur";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}