import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{(?:if ([^\\}]+)|(else)|(\\/if))\\}|^)([^\\{]*(?:(?!\\{(?:if [^\\}]+|else|\\/if)\\})\\{[^\\{]*)*)";
final String string = "{if $module=admin}\n"
+ "sdf\n"
+ "{else}\n"
+ "dsfsdf\n\n"
+ "{if $module=admin}\n"
+ "blah{invalid} blah\n\n"
+ "sdf\n"
+ "{/if}\n\n"
+ "{if $module=admin}\n"
+ "blah{invalid} blah\n"
+ "{else}\n"
+ "sdf\n"
+ "{/if}\n\n"
+ "{/if}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}