$re = '/(?:{(?:if ([^}]+)|(else)|(\/if))}|^)([^{]*(?:(?!{(?:if [^}]+|else|\/if)}){[^{]*)*)/';
$str = '{if $module=admin}
sdf
{else}
dsfsdf
{if $module=admin}
blah{invalid} blah
sdf
{/if}
{if $module=admin}
blah{invalid} blah
{else}
sdf
{/if}
{/if}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);