import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)^\\s*'?([\\w-]+)'?\\s*=\\s*(.*?)(?=^\\s*'?[\\w-]+'?\\s*=|\\Z)";
final String string = "COL1 = DEF1,\n"
+ "COL2 = DEF(TEST,\n"
+ "TEST2),\n"
+ "COL3 = FUN(1, 2),";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}