$re = '/(?sm)^\s*\'?([\w-]+)\'?\s*=\s*(.*?)(?=^\s*\'?[\w-]+\'?\s*=|\Z)/m';
$str = 'COL1 = DEF1,
COL2 = DEF(TEST,
TEST2),
COL3 = FUN(1, 2),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);