#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)((?<space>\s+)public\s+static\s+[^(]+\([^)]*?\)\s*\{.*?\k<space>\})|(public\s+static\s+[^(]+\([^)]*?\)\s*\{.*?\n\})"
Local $sString = "public static FieldsConfig getFieldsConfig(){" & @CRLF & _
" if(xxx) {" & @CRLF & _
" sssss;" & @CRLF & _
" }" & @CRLF & _
" return;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"NO CAPTURE" & @CRLF & _
"" & @CRLF & _
"public static FieldsConfig getFieldsConfig2(){" & @CRLF & _
" if(xxx) {" & @CRLF & _
" sssss;" & @CRLF & _
" }" & @CRLF & _
" return;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"NO CAPTURE" & @CRLF & _
"" & @CRLF & _
" public static FieldsConfig getFieldsConfig3(){" & @CRLF & _
" if(xxx) {" & @CRLF & _
" sssss;" & @CRLF & _
" }" & @CRLF & _
" return;" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
"NO CAPTURE" & @CRLF & _
"" & @CRLF & _
" public static FieldsConfig getFieldsConfig4(){" & @CRLF & _
" if(xxx) {" & @CRLF & _
" sssss;" & @CRLF & _
" }" & @CRLF & _
" return;" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")