package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-([^.]+)`)
var str = `[1] "A17-R-Null-C-3.AT2G41240" "A18-R-Null-C-3.AT2G41240" "B19-R-Null-C-3.AT2G41240"
[4] "B20-R-Null-C-3.AT2G41240" "A21-R-Transgenic-C-3.AT2G41240" "A22-R-Transgenic-C-3.AT2G41240"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}