// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-([^.]+)").unwrap();
let string = "[1] \"A17-R-Null-C-3.AT2G41240\" \"A18-R-Null-C-3.AT2G41240\" \"B19-R-Null-C-3.AT2G41240\"
[4] \"B20-R-Null-C-3.AT2G41240\" \"A21-R-Transgenic-C-3.AT2G41240\" \"A22-R-Transgenic-C-3.AT2G41240\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}