# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(".*?"|[^",]+)(?=\s*,|\s*$)//g;t' <<< "Hello World, b, c, \"d, e, f\",\" cs,sb v \",f
"