import re
regex = re.compile(r"(\".*?\"|[^\",]+)(?=\s*,|\s*$)")
test_str = ("Hello World, b, c, \"d, e, f\",\" cs,sb v \",f\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)