using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\d*\]((?=[^""]*(?:""[^""]*""[^""]*)*$)(?=[^']*(?:'[^']*'[^']*)*$))";
string input = @"select * as ""'[] [123]'"" from [] where [].[1] = '[][123]'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}