// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(\w+)Box\ \[\ ?([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+)\ +([-]?\d+|[-]?\d+\.\d+)\ *?\]").unwrap();
let string = "8 0 obj
<<
/Type /Page
/Parent 3 0 R
/Resources 9 0 R
/Contents [ 40 0 R 42 0 R 44 0 R 51 0 R 53 0 R 55 0 R 57 0 R 59 0 R ]
/TrimBox [ 42 42 2151 1573 ]
/BleedBox [ 36 36 2157 1579 ]
/MediaBox [ 0 0 2194 1615 ]
/CropBox [ 0 0 2194 1615 ]
/Rotate 0
>>
endobj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}