import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=^[^-].*\\n(?=- )|^- .*\\n(?!- ))";
final String string = "Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
+ "- red\n"
+ "- green\n"
+ "- blue\n"
+ "Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
+ "ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis\n"
+ "- red\n"
+ "- green\n"
+ "- blue\n"
+ "bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}