import re
regex = re.compile(r"(?m)(?<=^[^-].*\n(?=- )|^- .*\n(?!- ))", flags=re.IGNORECASE)
test_str = ("Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"- red\n"
"- green\n"
"- blue\n"
"Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis\n"
"- red\n"
"- green\n"
"- blue\n"
"bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)