package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\s+\d{1,2},\s+\d{4}`)
var str = `"Psg January 1, 2020 hsjkfsdlkfhshdfh January 2, 1908 hdhahhajshjdjoi December 31, 2019 fafsfafagherhea"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}