re = /\w+\s+\d{1,2},\s+\d{4}/m
str = '"Psg January 1, 2020 hsjkfsdlkfhshdfh January 2, 1908 hdhahhajshjdjoi December 31, 2019 fafsfafagherhea"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end